On MacOS, cmd-c copy does not work

Whenever I run a shell script within PyCharm, I can’t select text and copy it with cmd-c. I have to use the context menu for it to work. Since selecting and using cmd-c is so ingrained in my system, I keep running into this bug.
Other shortcuts that you would expect to work, like cmd-a to select everything, also don’t work.

@gmjonker Thanks for reporting!
Is this about cmd+c in the output panel of a script run configuration or about a different place where you expect it to work?

Yes, cmd-c in the output panel of a script run using a run configuration

For instance, I want to copy the selected text here using cmd-c.
Screen Shot 2021-05-07 at 15.27.23

I wasn’t able to reproduce this on macOS 10.15.7 with PyCharm Professional 2021.1.1 and BashSupport Pro

Could you share the information displayed at PyCharm > About PyCharm (copy with CMD+C), please?

Did you select the text snippet using the mouse or somehow else?

Is Cmd+C working as expected in the regular Terminal tool window?

By the way, Select All isn’t assigned by default in the IDEs. After assigning the shortcut at Preferences > Keymap > Plugins > Terminal > Select All it was in the run configuration output panel, at least for my setup. Choose “Leave” when a prompt about a conflict is shown.


PyCharm 2021.1.1 (Professional Edition)
Build #PY-211.7142.13, built on April 21, 2021
Licensed to Geert Jonker
Subscription is active until March 8, 2022.
Runtime version: 11.0.10+9-b1341.41 x86_64
VM: Dynamic Code Evolution 64-Bit Server VM by JetBrains s.r.o.
macOS 11.3.1
GC: G1 Young Generation, G1 Old Generation
Memory: 2000M
Cores: 16
Non-Bundled Plugins: FrameSwitcher (3.26.1-203), String Manipulation (, org.sylfra.idea.plugins.linessorter (1.0.1), org.toml.lang (, pro.bashsupport (, net.fhtagn.pycharm.cellmode (1.2.1)

Text is selected with the mouse indeed.

Yes it is.

I’ve debugged and tested this for a while on a machine with macOS 11.3, but still can’t reproduce this, even with the 3rd-party plugins you’ve installed.

  • Could you post a screenshot of Preferences > Tools > Terminal, please?

The only problem I found is that Copy to clipboard on selection isn’t working in the BashSupport Pro output panel, just with the regular Terminal panel. But this still doesn’t explain why Cmd+C isn’t working at all.
If you have this setting enabled, does disabling it make any difference?

Sample screenshot of the settings:

I think I found the culprit: the Cell Mode plugin. Disabling that makes the problem go away.

Thanks for the support, this gave me the idea to try to disable this plugin!