Markdown language injection with "bash" instead of "bashpro shell script"?

Hi there,

With the legacy plugin, markdown language injection could be done by simply saying bash after the triple backticks. Is there a way to avoid rewriting all shell scripts to use bashpro shell script to enable language injection with the new plugin? Also to me using a vendor name here seems wrong to me.

Thanks & Best

Hi @holgerbrandl,
are you on the latest version of BashSupport Pro?

1.4.11 should have fixed this. bash, sh, and zsh should automatically trigger the injection and also show up when you call auto completion after the opening fence block.
Does that work for you? If that’s not the case, please pase the info at Help>About>Ctrl/Cmd+C and paste it here.

Currently only the JetBrains Markdown plugin is supported. Let me know if you’re using something else.

By default, the IDs supported by the Markdown plugin are the names of the languages. “Shell Script” is taken by the JetBrains plugin and “Bash” by legacy BashSupport. I had to pick something else. It might not have been the best choice, though.


Hi Joachim,

thanks for the support and the amazing response time.

I’m on

Indeed, I’m not using the JB markdown plugin, but Markdown Navigator (see


I see, Markdown Navigator isn’t support at this time. I’ll check if there’s an extension in that plugin I could support. I’ve opened for this.

Hi @holgerbrandl,
I had a chance to look at this and included the change in the eap release I was preparing.

I’ve published an EAP release with the latest changes: and If you want to test that, download the file and install via Settings>Plugins>Install from disk or just drag&drop the file onto the main window.

The change will be shipped with the next stable release later this month.


Works just great. Thank you so much for your great support.



btw, replying to the email notification does not seem to append to this thread. Not sure if this is intended.

This is finally available for everyone. Version 1.5.8 has been released today.
(reply by email hasn’t been configured properly yet. I’ll take a look at that.)