Can't run debug on mac os mojave

Latest version of the BashSupport Pro ( Trial, on latest version of the WebStorm.

WebStorm 2020.2
Build #WS-202.6397.88, built on July 24, 2020
Licensed to Oleg Taranenko Softwareentwicklung / Oleg Taranenko
Subscription is active until December 26, 2020
Runtime version: 11.0.7+10-b944.20 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 10.14.6
GC: ParNew, ConcurrentMarkSweep
Memory: 1631M
Cores: 12
Non-Bundled Plugins: com.alayouni.ansiHighlight, com.carbonblack.intellij.rpmspec, com.jinsihou.react.snippets, in.thekalinga.snippet.intellij, org.sylfra.idea.plugins.linessorter, org.toml.lang, org.weebly.generator, pro.bashsupport, com.intellij.react.css.modules, com.hasintech.intellij.angularTemplates, com.suming.react.PropTypes, ru.adelf.idea.dotenv

By trying Debug getting Red Balloon

03:02 Error running ‘’: Debugging is only possible with GNU Bash, versions 4 or 5, but version 3 was detected

bash is installed via Macports
port install bash

Mac-Pro:agc user1$ which bash

Mac-Pro:agc user1$ bash --version
GNU bash, version 5.0.17(1)-release (x86_64-apple-darwin18.7.0)
Copyright © 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later

This is free software; you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.


Mac-Pro:agc user1$ /bin/bash --version
GNU bash, version 3.2.57(1)-release (x86_64-apple-darwin18)
Copyright © 2007 Free Software Foundation, Inc.

How to work around?

Cheers, Oleg

Thanks for reporting, @olegtaranenko!

This path is not yet detected automatically. I’ll add that for the next update. Currently, only bash installed by homebrew is detected automatically.

Here’s how to make this work:

  1. open the settings at Preferences... > Languages & Frameworks > BashSupport Pro
  2. add a new item in the table of interpreters:
    • Path : /opt/local/bin/bash
    • Type: Bash
  3. Move it to the top position. The debugging picks the first item in that list which has type “Bash”.

It should look like this (optionally with more items below):

Please let me know if this isn’t working for you.


Hi @jansorg,
no, not helping, still
18:04 Error running ‘’: Debugging is only possible with GNU Bash, versions 4 or 5, but version 3 was detected

I have tried to do this on the macOS Catalina (I have another notebook) and figured out weird bahaviour, I can’t activate BashSupport Pro on it. Every time starting I’m asked about license for Bash Pro, I selected Evaluate, then Restart WebStorm and … again I have to select Evaluate options -> Do you want to restart WebStorm …

Hi @olegtaranenko,

  1. regarding the run configuration: It’s possible that the configuration is defining a fixed path to the interpreter, like this:

    This is used by the debugger if it’s pointing to a Bash interpreter.

If this is set, please change this to either use the project interpreter or set this to /opt/local/bin/bash and try to run the debugger again.
If this still isn’t working for you, please post a screenshot of your run configuration.

  1. regarding the install issue: that’s weird. I just tried with a new user account on Catalina. It worked for me and did not ask for a restart after selecting the evaluation license, but showed a “Continue” button.
    It should be possible to close the license popup and to start WebStorm without a new evaluation license for BashSupport Pro. Could you do that, invoke Help > Collect Logs and Diagnostic Data and send the file to
    I’m sorry that this a bit complicated. This is all in WebStorm and plugins don’t have control over the registration popup and the restart behaviour.


Thanks, Joachim.

if I explicitly assign current script to the “custom interpreter” -> /opt/local/bin/bash, Debug works. Otherwise no joy. Regarding weirdness on the Catalina, will look a bit later

Anyway thank you for great tool