Can't get plugin to recognize file by shebang

I’m using BashSupport 1.7.7 with IntelliJ 2018.3.6. I tried to follow the directions on making the plugin look for the #!/bin/bash in files without extensions but there is a reference “the other option” which is not clear. The screen shot looks like an older (newer?) version of IntelliJ. What am I missing?

Never mind. My “#!/bin/bash” was missing the “!”. When I renamed the file with a .sh extension, I was prompted to add it and my attention was drawn to the typo.